Maven

Eclipse Maven 编译错误 Dynamic Web Module 3.0 requires Java 1.6 or newer

eclipse报错Dynamic Web Module 3.0 requires Java 1.6 or newer,如图示:

20150826094114680.jpg

排查错误:

1、检查eclipse的jdk版本,看是否符合版本

20150826094308753.jpg

2、如果上面的jdk版本没有问题,则更改pom文件,在pom文件中添加以下代码,之后重新编译maven:

<build>  
    <plugins>  
        <!-- define the project compile level -->  
        <plugin>  
            <groupId>org.apache.maven.plugins</groupId>  
            <artifactId>maven-compiler-plugin</artifactId>  
            <version>2.3.2</version>  
            <configuration>  
                <source>1.7</source>  
                <target>1.7</target>  
            </configuration>  
        </plugin>  
    </plugins>  
</build>

留言

您的电子邮箱地址不会被公开。 必填项已用*标注